aboutsummaryrefslogtreecommitdiff
path: root/backend/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'backend/Cargo.toml')
-rw-r--r--backend/Cargo.toml17
1 files changed, 12 insertions, 5 deletions
diff --git a/backend/Cargo.toml b/backend/Cargo.toml
index 42933e5..b44b5ad 100644
--- a/backend/Cargo.toml
+++ b/backend/Cargo.toml
@@ -6,11 +6,18 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-rocket = "0.4.10"
-diesel = { version = "1.4.4", features = ["postgres"] }
+rocket = { version= "0.5.0-rc.1", features = ["json"] }
+diesel = { version = "1.4.4", features = ["postgres", "r2d2"] }
dotenv = "0.15.0"
+rust-argon2 = "0.8"
+rand = "0.8.4"
+serde = { version = "1.0", features = ["derive"] }
+serde_bytes = "0.11"
+chrono = { version = "0.4", features = ["serde"] }
+serde_json = "1.0"
+base64 = "0.13.0"
-[dependencies.rocket_contrib]
-version = "0.4.10"
-default-features = false
+
+[dependencies.rocket_sync_db_pools]
+version = "0.1.0-rc.1"
features = ["diesel_postgres_pool"] \ No newline at end of file