aboutsummaryrefslogtreecommitdiff
path: root/planetwars-cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'planetwars-cli/Cargo.toml')
-rw-r--r--planetwars-cli/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/planetwars-cli/Cargo.toml b/planetwars-cli/Cargo.toml
new file mode 100644
index 0000000..e1f0a8e
--- /dev/null
+++ b/planetwars-cli/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "planetwars-cli"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[[bin]]
+name = "pwcli"
+
+[dependencies]
+futures-core = "0.3"
+futures = "0.3"
+tokio = { version = "1", features = ["full"] }
+rand = "0.6"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+toml = "0.5"
+planetwars-rules = { path = "../planetwars-rules" }
+clap = { version = "3.0.0-rc.8", features = ["derive"] }
+chrono = { version = "0.4", features = ["serde"] }
+shlex = "1.1"
+
+rust-embed = "6.3.0"
+axum = { version = "0.4", features = ["ws"] }
+mime_guess = "2" \ No newline at end of file