aboutsummaryrefslogtreecommitdiff
path: root/web/pw-frontend/planetwars-rs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'web/pw-frontend/planetwars-rs/Cargo.toml')
-rw-r--r--web/pw-frontend/planetwars-rs/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/web/pw-frontend/planetwars-rs/Cargo.toml b/web/pw-frontend/planetwars-rs/Cargo.toml
new file mode 100644
index 0000000..31b4d6c
--- /dev/null
+++ b/web/pw-frontend/planetwars-rs/Cargo.toml
@@ -0,0 +1,44 @@
+[package]
+name = "planetwars-rs"
+version = "0.1.0"
+authors = ["ajuvercr <arthur.vercruysse@ugent.be>"]
+edition = "2018"
+
+[package.metadata.wasm-pack.profile.release]
+wasm-opt = ["-Oz", "--enable-mutable-globals"]
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[features]
+default = ["console_error_panic_hook"]
+
+[dependencies]
+wasm-bindgen = "0.2"
+
+# The `console_error_panic_hook` crate provides better debugging of panics by
+# logging them with `console.error`. This is great for development, but requires
+# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
+# code size when deploying.
+console_error_panic_hook = { version = "0.1.1", optional = true }
+
+# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
+# compared to the default allocator's ~10K. It is slower than the default
+# allocator, however.
+#
+# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
+wee_alloc = { version = "0.4.2", optional = true }
+serde = "1.0.100"
+serde_derive = "1.0.100"
+serde_json = "1.0"
+octoon-math = "0.1.7"
+voronoi = "0.1.4"
+
+[dev-dependencies]
+wasm-bindgen-test = "0.2"
+
+[profile.release]
+# Tell `rustc` to optimize for small code size.
+opt-level = "s"
+
+[workspace] \ No newline at end of file