aboutsummaryrefslogtreecommitdiff
path: root/planetwars-client/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-07-04 20:16:42 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-07-04 20:16:42 +0200
commit268e080ec1b11e75309c3b134e16cf6ea7004ac6 (patch)
tree6cf54c91b4575494f1f2c2feb7790aadae817eb7 /planetwars-client/Cargo.toml
parentbbed87755419f97b0ee8967617af0c6573c168af (diff)
parent7a3b801f58752a78b65e3e7e7b998b6479f980f7 (diff)
downloadplanetwars.dev-268e080ec1b11e75309c3b134e16cf6ea7004ac6.tar.xz
planetwars.dev-268e080ec1b11e75309c3b134e16cf6ea7004ac6.zip
Merge branch 'bot-api' into next
Diffstat (limited to 'planetwars-client/Cargo.toml')
-rw-r--r--planetwars-client/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/planetwars-client/Cargo.toml b/planetwars-client/Cargo.toml
new file mode 100644
index 0000000..9c68391
--- /dev/null
+++ b/planetwars-client/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "planetwars-client"
+version = "0.0.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+tokio = { version = "1.15", features = ["full"] }
+tokio-stream = "0.1.9"
+prost = "0.10"
+tonic = "0.7.2"
+serde = { version = "1.0", features = ["derive"] }
+toml = "0.5"
+planetwars-matchrunner = { path = "../planetwars-matchrunner" }
+
+[build-dependencies]
+tonic-build = "0.7.2"