aboutsummaryrefslogtreecommitdiff
path: root/planetwars-matchrunner/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-01-01 12:10:02 +0100
committerIlion Beyst <ilion.beyst@gmail.com>2022-01-01 12:10:02 +0100
commit4a077c7c65eced447c45389acf05007dd571bf26 (patch)
treef291c61c6164a58fb1d3ab66952d07d0b7e4609c /planetwars-matchrunner/Cargo.toml
parente145947d052450618af3ba094e66a27c3c7f86e4 (diff)
downloadplanetwars.dev-4a077c7c65eced447c45389acf05007dd571bf26.tar.xz
planetwars.dev-4a077c7c65eced447c45389acf05007dd571bf26.zip
extract matchrunner crate from planetwars-cli
Diffstat (limited to 'planetwars-matchrunner/Cargo.toml')
-rw-r--r--planetwars-matchrunner/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/planetwars-matchrunner/Cargo.toml b/planetwars-matchrunner/Cargo.toml
new file mode 100644
index 0000000..da05f13
--- /dev/null
+++ b/planetwars-matchrunner/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "planetwars-matchrunner"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+futures-core = "0.3"
+futures = "0.3"
+tokio = { version = "1", features = ["full"] }
+rand = "0.6"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+planetwars-rules = { path = "../planetwars-rules" }
+chrono = { version = "0.4", features = ["serde"] } \ No newline at end of file