aboutsummaryrefslogtreecommitdiff
path: root/planetwars-server/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-07-04 20:16:42 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-07-04 20:16:42 +0200
commit268e080ec1b11e75309c3b134e16cf6ea7004ac6 (patch)
tree6cf54c91b4575494f1f2c2feb7790aadae817eb7 /planetwars-server/Cargo.toml
parentbbed87755419f97b0ee8967617af0c6573c168af (diff)
parent7a3b801f58752a78b65e3e7e7b998b6479f980f7 (diff)
downloadplanetwars.dev-268e080ec1b11e75309c3b134e16cf6ea7004ac6.tar.xz
planetwars.dev-268e080ec1b11e75309c3b134e16cf6ea7004ac6.zip
Merge branch 'bot-api' into next
Diffstat (limited to 'planetwars-server/Cargo.toml')
-rw-r--r--planetwars-server/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/planetwars-server/Cargo.toml b/planetwars-server/Cargo.toml
index 99161bb..f2444c1 100644
--- a/planetwars-server/Cargo.toml
+++ b/planetwars-server/Cargo.toml
@@ -8,6 +8,7 @@ edition = "2021"
[dependencies]
futures = "0.3"
tokio = { version = "1.15", features = ["full"] }
+tokio-stream = "0.1.9"
hyper = "0.14"
axum = { version = "0.5", features = ["json", "headers", "multipart"] }
diesel = { version = "1.4.4", features = ["postgres", "chrono"] }
@@ -29,9 +30,14 @@ config = { version = "0.12", features = ["toml"] }
thiserror = "1.0.31"
sha2 = "0.10"
tokio-util = { version="0.7.3", features=["io"] }
+prost = "0.10"
+tonic = "0.7.2"
# TODO: remove me
shlex = "1.1"
+[build-dependencies]
+tonic-build = "0.7.2"
+
[dev-dependencies]
parking_lot = "0.11"