aboutsummaryrefslogtreecommitdiff
path: root/planetwars-server/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-08-09 23:27:22 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-08-09 23:27:22 +0200
commit406c7266019c0c36cfe5069bfe5cf293badd3a30 (patch)
tree1f5d054add282f45d9ff14de7a62160ff7ca31b2 /planetwars-server/Cargo.toml
parent58c1c5f9fb48040ad6b0891d586543c219de74d2 (diff)
downloadplanetwars.dev-406c7266019c0c36cfe5069bfe5cf293badd3a30.tar.xz
planetwars.dev-406c7266019c0c36cfe5069bfe5cf293badd3a30.zip
create password reset utility
Co-authored-by: Wout Schellaert <wout.schellaert@gmail.com>
Diffstat (limited to 'planetwars-server/Cargo.toml')
-rw-r--r--planetwars-server/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/planetwars-server/Cargo.toml b/planetwars-server/Cargo.toml
index f2444c1..2b3916c 100644
--- a/planetwars-server/Cargo.toml
+++ b/planetwars-server/Cargo.toml
@@ -2,8 +2,16 @@
name = "planetwars-server"
version = "0.0.0"
edition = "2021"
+default-run = "planetwars-server"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[[bin]]
+name = "planetwars-server"
+path = "src/main.rs"
+
+[[bin]]
+name = "planetwars-server-cli"
+path = "src/cli.rs"
[dependencies]
futures = "0.3"
@@ -32,6 +40,7 @@ sha2 = "0.10"
tokio-util = { version="0.7.3", features=["io"] }
prost = "0.10"
tonic = "0.7.2"
+clap = { version = "3.2", features = ["derive", "env"]}
# TODO: remove me
shlex = "1.1"