aboutsummaryrefslogtreecommitdiff
path: root/planetwars-server/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-10-12 22:52:15 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-10-12 22:52:15 +0200
commitae57359353cf31ff374a8932999742920878bf00 (patch)
tree0db27d394a2a61a5cc94e73014c82954829c1338 /planetwars-server/Cargo.toml
parented016773b112460ebbf0ff023b0915545229ed41 (diff)
downloadplanetwars.dev-ae57359353cf31ff374a8932999742920878bf00.tar.xz
planetwars.dev-ae57359353cf31ff374a8932999742920878bf00.zip
upgrade to diesel 2.0
Diffstat (limited to 'planetwars-server/Cargo.toml')
-rw-r--r--planetwars-server/Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/planetwars-server/Cargo.toml b/planetwars-server/Cargo.toml
index f5641d1..183bb90 100644
--- a/planetwars-server/Cargo.toml
+++ b/planetwars-server/Cargo.toml
@@ -15,15 +15,15 @@ path = "src/cli.rs"
[dependencies]
futures = "0.3"
-tokio = { version = "1.15", features = ["full"] }
+tokio = { version = "1.21", features = ["full"] }
tokio-stream = "0.1.9"
hyper = "0.14"
tower-http = { version = "0.3.4", features = ["full"] }
axum = { version = "0.5", features = ["json", "headers", "multipart"] }
-diesel = { version = "1.4.4", features = ["postgres", "chrono"] }
-diesel-derive-enum = { version = "1.1", features = ["postgres"] }
-bb8 = "0.7"
-bb8-diesel = "0.2"
+diesel = { version = "2.0", features = ["postgres", "chrono"] }
+diesel-derive-enum = { version = "2.0.0-rc.0", features = ["postgres"] }
+bb8 = "0.8"
+bb8-diesel = { git = "https://github.com/overdrivenpotato/bb8-diesel.git" }
dotenv = "0.15.0"
rust-argon2 = "0.8"
rand = "0.8.4"