aboutsummaryrefslogtreecommitdiff
path: root/planetwars-server/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-06-12 21:03:41 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-06-12 21:03:41 +0200
commitdde0bc820e47a372c9b1042249637c708a323188 (patch)
tree633469d62179969828537076f4f9c5ea1e5497bf /planetwars-server/Cargo.toml
parentcf248ff41ac3510e608804937b0a05d4d4ffc758 (diff)
downloadplanetwars.dev-dde0bc820e47a372c9b1042249637c708a323188.tar.xz
planetwars.dev-dde0bc820e47a372c9b1042249637c708a323188.zip
accept docker push
Diffstat (limited to 'planetwars-server/Cargo.toml')
-rw-r--r--planetwars-server/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/planetwars-server/Cargo.toml b/planetwars-server/Cargo.toml
index 4c6ddfc..3e1f05e 100644
--- a/planetwars-server/Cargo.toml
+++ b/planetwars-server/Cargo.toml
@@ -6,6 +6,7 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+futures = "0.3"
tokio = { version = "1.15", features = ["full"] }
hyper = "0.14"
axum = { version = "0.4", features = ["json", "headers", "multipart"] }
@@ -26,6 +27,7 @@ toml = "0.5"
planetwars-matchrunner = { path = "../planetwars-matchrunner" }
config = { version = "0.12", features = ["toml"] }
thiserror = "1.0.31"
+sha2 = "0.10"
# TODO: remove me
shlex = "1.1"