aboutsummaryrefslogtreecommitdiff
path: root/planetwars-localdev/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'planetwars-localdev/Cargo.toml')
-rw-r--r--planetwars-localdev/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/planetwars-localdev/Cargo.toml b/planetwars-localdev/Cargo.toml
new file mode 100644
index 0000000..31c403d
--- /dev/null
+++ b/planetwars-localdev/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "planetwars-localdev"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[[bin]]
+name = "pwcli"
+
+[dependencies]
+futures-core = "0.3"
+futures = "0.3"
+tokio = { version = "1", features = ["full"] }
+rand = "0.6"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+toml = "0.5"
+planetwars-rules = { path = "../planetwars-rules" }
+clap = { version = "3.0.0-rc.8", features = ["derive"] }
+chrono = "0.4"
+
+rust-embed = "6.3.0"
+axum = "0.4"
+mime_guess = "2" \ No newline at end of file