aboutsummaryrefslogtreecommitdiff
path: root/planetwars-matchrunner/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'planetwars-matchrunner/Cargo.toml')
-rw-r--r--planetwars-matchrunner/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/planetwars-matchrunner/Cargo.toml b/planetwars-matchrunner/Cargo.toml
new file mode 100644
index 0000000..da05f13
--- /dev/null
+++ b/planetwars-matchrunner/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "planetwars-matchrunner"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+futures-core = "0.3"
+futures = "0.3"
+tokio = { version = "1", features = ["full"] }
+rand = "0.6"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+planetwars-rules = { path = "../planetwars-rules" }
+chrono = { version = "0.4", features = ["serde"] } \ No newline at end of file