aboutsummaryrefslogtreecommitdiff
path: root/backend/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2021-12-29 16:11:27 +0100
committerIlion Beyst <ilion.beyst@gmail.com>2021-12-29 16:11:27 +0100
commit1fb4a5151bd8cfe6de4d8c19e2066a9281a0b61a (patch)
tree4adc79684acdcd703e2319e3444af66489623ebd /backend/Cargo.toml
parent52242b03f1af7f73e73592c2e5ee2bc54813a64d (diff)
downloadplanetwars.dev-1fb4a5151bd8cfe6de4d8c19e2066a9281a0b61a.tar.xz
planetwars.dev-1fb4a5151bd8cfe6de4d8c19e2066a9281a0b61a.zip
migrate to axum
Diffstat (limited to 'backend/Cargo.toml')
-rw-r--r--backend/Cargo.toml13
1 files changed, 6 insertions, 7 deletions
diff --git a/backend/Cargo.toml b/backend/Cargo.toml
index ed64ac3..de98df7 100644
--- a/backend/Cargo.toml
+++ b/backend/Cargo.toml
@@ -6,8 +6,12 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-rocket = { version= "0.5.0-rc.1", features = ["json"] }
-diesel = { version = "1.4.4", features = ["postgres", "r2d2", "chrono"] }
+tokio = { version = "1.15", features = ["full"] }
+hyper = "0.14"
+axum = { version = "0.4", features = ["json", "headers"] }
+diesel = { version = "1.4.4", features = ["postgres", "chrono"] }
+bb8 = "0.7"
+bb8-diesel = "0.2"
dotenv = "0.15.0"
rust-argon2 = "0.8"
rand = "0.8.4"
@@ -18,10 +22,5 @@ serde_json = "1.0"
base64 = "0.13.0"
zip = "0.5"
-
-[dependencies.rocket_sync_db_pools]
-version = "0.1.0-rc.1"
-features = ["diesel_postgres_pool"]
-
[dev-dependencies]
parking_lot = "0.11" \ No newline at end of file