aboutsummaryrefslogtreecommitdiff
path: root/planetwars-client/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2022-07-22 23:50:52 +0200
committerIlion Beyst <ilion.beyst@gmail.com>2022-07-22 23:50:52 +0200
commit1cf20810c5191c426f9226a13f4a0d0e09c8f74b (patch)
tree48a3e755c208bd8074753091a6dcda8b9efafa1e /planetwars-client/Cargo.toml
parentfe2f382e0478b13e57a8e79a4c4c5a919f0d1a33 (diff)
downloadplanetwars.dev-1cf20810c5191c426f9226a13f4a0d0e09c8f74b.tar.xz
planetwars.dev-1cf20810c5191c426f9226a13f4a0d0e09c8f74b.zip
enable ssl for grpc client
Diffstat (limited to 'planetwars-client/Cargo.toml')
-rw-r--r--planetwars-client/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/planetwars-client/Cargo.toml b/planetwars-client/Cargo.toml
index 69a72a6..4ff96f2 100644
--- a/planetwars-client/Cargo.toml
+++ b/planetwars-client/Cargo.toml
@@ -9,7 +9,7 @@ edition = "2021"
tokio = { version = "1.15", features = ["full"] }
tokio-stream = "0.1.9"
prost = "0.10"
-tonic = "0.7.2"
+tonic = { version = "0.7.2", features = ["tls", "tls-roots"] }
serde = { version = "1.0", features = ["derive"] }
toml = "0.5"
planetwars-matchrunner = { path = "../planetwars-matchrunner" }