aboutsummaryrefslogtreecommitdiff
path: root/web/planetwars-rs/Cargo.toml
diff options
context:
space:
mode:
authorIlion Beyst <ilion.beyst@gmail.com>2021-12-29 21:24:57 +0100
committerIlion Beyst <ilion.beyst@gmail.com>2021-12-29 21:25:29 +0100
commit0c6d978442b244ca3f29c1ffdd44b5007ae7ad93 (patch)
treebaae5fa459a49ecd362e548e0649e2f58c669a70 /web/planetwars-rs/Cargo.toml
parent3eeaab6cec70e7a06a99a1ac2662974f71064bee (diff)
downloadplanetwars.dev-0c6d978442b244ca3f29c1ffdd44b5007ae7ad93.tar.xz
planetwars.dev-0c6d978442b244ca3f29c1ffdd44b5007ae7ad93.zip
separate out visualizer library
Diffstat (limited to 'web/planetwars-rs/Cargo.toml')
-rw-r--r--web/planetwars-rs/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/web/planetwars-rs/Cargo.toml b/web/planetwars-rs/Cargo.toml
new file mode 100644
index 0000000..a5dc949
--- /dev/null
+++ b/web/planetwars-rs/Cargo.toml
@@ -0,0 +1,44 @@
+[package]
+name = "planetwars-rs"
+version = "0.1.0"
+authors = ["ajuvercr <arthur.vercruysse@ugent.be>"]
+edition = "2018"
+
+[package.metadata.wasm-pack.profile.release]
+wasm-opt = ["-Oz", "--enable-mutable-globals"]
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[features]
+default = ["console_error_panic_hook"]
+
+[dependencies]
+wasm-bindgen = "0.2.63"
+
+# The `console_error_panic_hook` crate provides better debugging of panics by
+# logging them with `console.error`. This is great for development, but requires
+# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
+# code size when deploying.
+console_error_panic_hook = { version = "0.1.6", optional = true }
+
+# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
+# compared to the default allocator's ~10K. It is slower than the default
+# allocator, however.
+#
+# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
+wee_alloc = { version = "0.4.5", optional = true }
+serde = "1.0.100"
+serde_derive = "1.0.100"
+serde_json = "1.0"
+octoon-math = "0.1.7"
+voronoi = "0.1.4"
+
+[dev-dependencies]
+wasm-bindgen-test = "0.3.13"
+
+[profile.release]
+# Tell `rustc` to optimize for small code size.
+opt-level = "s"
+
+[workspace] \ No newline at end of file